64-bit compatibility

Here you’ll find some information regarding compatibility of Troi Plug-ins with FileMaker running in 64-bit mode.

64-bit plug-ins are needed for 64-bit FileMaker processes

FileMaker Pro (Advanced) 15 and 14, FileMaker Server (Advanced) 15, 14 and 13 and WebDirect are 64-bit processes, for which plug-ins need to be compiled for 64-bit. On Windows, 64-bit plug-ins have a different extension: fmx64. In the download of a 64-bit compatible plug-in you will find this extra copy of the plug-in. Plug-ins for macOS can be universal and the extension is always the same: fmplugin. A universal plug-in is a single plug-in that will run on a 32-bit process as well as on 64-bit process. You can not easily see if a macOS plug-in is 64-bit compatible. We have created a simple dropper app called “Troi Architecture Check” to determine for which architectures a plug-in is compiled. You can download the app here.

64-bit Troi Plug-ins

In the below list you can verify which of our current plug-ins has been compiled for 64-bit:

version*64-bitremarks
Activator Plug-in3.6Yes!
Dialog Plug-in6.1Yes!
Encryptor Plug-in3.0Yes!
File Plug-in8.0Yes!
Grabber Plug-in2.3No
Serial Plug-in4.0Yes!
Text Plug-in3.5Yes!
URL Plug-in4.1Yes!

* This is the first version to be compiled for 64-bit